Thursday, 9 June 2016

Batch file for starting Maximo services

sc start "IBMHTTPServerV8.5"
timeout 5

sc start "IBMWAS85Service - ctgCellManager01"
timeout 5

sc start "IBMWAS85Service - ctgNode01"
pause

Adding Hover Dialogs to additional fields in Maximo 7.6

Question

How can I add Hover Dialogs to additional fields in Maximo 7.6?

Answer

Hover Dialogs are a new feature in Maximo 7.6 that display additional information
related to a field when you hover your mouse over the field. For example in the image
below, if you hover over the Reported By field in Work Order Tracking, it will display
additional details on the value in the field. The hover option is only available if there is
an existing value in the field.



These hover dialogs are set up by default on a number of fields in various applications
and based on the following attributes:
- Asset
- Item
- Person
- Work Order

In order to add an additional hover dialog go to System Configuration / Platform Configuration / Application Designer and pull up the application your field is in (in this example that is the
Supervisor field in the Labor application). Next right click on the field, select "Properties", and then click on the Advanced tab. Add PERSON_RECORDHOVER in the Hover Window ID textbox to
add more person details and then save your changes.



Now when you Go To the Labor application and if your Supervisor field has a value in it, then
hovering over the field will show additional details about the supervisor.



Please note that the hover dialogue only works when there is a field validation class, or a table domain connected to the attribute. If you add hover functionality to an attribute which doesn't have a field validation class, such as the ASSET.CHANGEBY, or SR.ENTEREDBY, then the hover dialog will display but it is blank, it does not show any data.

Tuesday, 24 May 2016

Asset Field Automatically Filled in PM Work Order

Problem(Abstract)

In Maximo, if you are generating a work order from a PM record, the asset field will be automatically populated on the generated work order if the location field if the PM has a single asset on it.

Resolving the problem

Regarding the PM generated work order filling asset field automatically, the system automatically adds a single asset for you on tasks generated from job plans on PM WOs even though no asset was specified on either (just a location) if there is only one asset in the hierarchy under that location.

When creating a PM for a location who has only one associated asset, will generate a work order with the location and the asset.

The reason for this is that the location and the asset have a one to one relationship.

There are a few Workarounds;

1. Associate another ASSET/EQUIPMENT to the LOCATION (even if it's a DUMMY asset)

2. Remove the ASSET/EQUIPMENT from the workorder when the workorder is Generated


If the workorder is not editable due to the workorder being in WSCH or in APPR status, you can do the following;

Change the WPEDIT settings for the ASSET Field to make it Editable in APPR status

This has been reported before, and the following enhancement request has been previously submitted:

MR091907688 - Issue WO against location having one and only one asset

[Default behavior of standard Maximo]

(1) There exists one-to-one correspondence between asset and its associated location. When PM work order against the location is created by CronTask, due to that associated asset is automatically filled in by CronTask, auto-filled asset must be discarded manually. If an user specifies location upon creating PM work order against the location, PM work order application automatically fills in the associated asset in asset field on PM work order detail screen.

(2) When PM work order is manually created against location with only one asset associated as its child, the same situation occurs to PM work order. PM work order is issued against the asset instead of location which is one level upper in the hierarchy, a user intends to create PM work order against the location, though.


[Enhancement Request]
In work order tracking application, discard auto fill for asset field when newly creating PM work order against location having only one asset as its child.

This enhancement request has been acknowledged.

Should you need any assistance, please contact IBM Maximo Support

Error Trying to Change Work Order Status to Closed

Problem(Abstract)

BMXAA4590E - Could not change Work Order XXXX status to CLOSE. BMXAA4129E - Record already exists for Site=TEST, Work Order=XXXX, Asset=YYYY.

Symptom

Unable to change work orders to closed status.

Cause

This can be caused by closing work orders via the application and then re-opening them via the database.

Diagnosing the problem

Run the following select statements:
Select * from ASSETHIERARCHY where wonum = 'XXXX' and siteid = 'TEST';

Select * from ASSETHISTORY where wonum = 'XXXX' and siteid = 'TEST';

If the work order is still open/completed but not closed there should be no rows in the database for the ASSETHIEARCHY table.

Resolving the problem

You can either update the row by adding a value to the wonum so that the row is retained for historical purposes.....

update assethierarchy set wonum = 'XXXXA' where wonum = 'XXXX'
and siteid = 'TEST' and assetnum = 'YYYY';

......or simply delete the row.

Return to the application and attempt to close the work order.

Error: BMXAA4590E - Could Not Change Work Status to CLOSE


Problem(Abstract)

Unable to close a work order.

Symptom

When trying to change work order status from Complete to Close, you receive the error:
BMXAA4590E Could not change Work Order status to Close.
BMXAA4129E Record already exists for site=BEDFORD, Work Order=12345, Asset=
TRUCK.
Confirm that the key value for the given record is unique.

Cause

This could be caused by a data issue. If a record is set to complete via the front end it may actually be closed in the WOSTATUS table.

The same work order record exists in both ASSETHIERARCHY and ASSETHISTORY tables with the same asset number.

Resolving the problem

Delete the record from the ASSETHIERARCHY and ASSETHISTORY tables. At this point, you should be able to close the work order without issue

Creating summary or detail Query-Based Reports in cloned (duplicated) applications


Technote (FAQ)


Question

From Maximo 7.1.1.6 onwards, you can create Summary or Detail Query-Based-Report (QBR). But in cloned applications, the option to select the type of QBR is disabled. How can you enable that option?

Answer

The steps below will show how to create the Summary or Detail QBR in cloned applications with an example:
1. Go to Application Designer - Open the WOTRACK application.
2. Select Action - Duplicate Application Definition - Create WOTRACK2 application with the description 'Work Order Tracking 2'.
3. Go to Security Group - Give adequate privileges for the WOTRACK2 application to the security group, for example MAXADMIN.
4. Login again and open the WOTRACK2 application.
5. Click on the 'Create Report' toolbar button to create the Query-Based-Report.
As you can see below, the option to be able to select the style of report ( Summary or Detail Report) is not enabled.



By default, all cloned (duplicated) applications have the same problem.
In order to enable the option above, please follow the steps below:
When the WOTRACK2 application is cloned from WOTRACK , the WOTRACK2 application has the same report object as the original application WOTRACK.
For example:



1. Create the report object for the cloned application (WOTRACK2).
Go to the Integration / Object Structures application - Find 'REP_WORKORDER' .
Based on 'REP_WORKORDER', create the new report object for WOTRACK2 called 'REP_WO2' (you can also duplicate 'REP_WORKORDER' to create 'REP_WO2' )
-- Object Structure : REP_WO2
-- Description : Work Order Details 2
-- Consumed By : REPORTING
-- Application : WOTRACK2


2. Save the record.
3. Go to the Report Administration application.
4. Run Select Action / Set Report Object Structure Security.
5. Filter application with the value 'Work Order Tracking 2' . You can see the newly-created report object 'REP_WO2' for WOTRACK2 application.
P.S. : the WOTRACK2 application's description is 'Work Order Tracking 2'.
The REP_WO2 report object's description is 'Work Order Details 2'.



6. Now you need to define any security groups who can access the newly-created report object .
- Click New Row
- Add the 'MAXADMIN' group.



7. Go to the 'Work Order Tracking 2' application (WOTRACK2)
Try to run 'Create Report'. Now you can select the style for the QBR report (Summary or Detail).

Setting up Password Expiration in Maximo


Question

How to set up password expiration in Maximo.

Answer

Password Expiration can be set in a few places in Maximo. The default setting is set In the Security Groups application, in the Select Action menu, using the Security Controls option.
All new groups created after this setting is made will inherit this value, however any groups that existed prior to this setting being in place will not get updated.
This value only gets referenced when a new group is created.
If a group is created and has inherited the value, then the value is changed in the Security Controls option, the groups that existed prior to this change will not be updated.
For this reason, when setting up Maximo for the first time, it may be better to decide on a default password expiration value and have that value in place prior to creating your groups.
Once the value for a group has been set, or if no value has been set prior to creating the group, you can update the password expiration setting by using the Override Password Duration option in the Select Action menu of Security Groups.
This also allows you set a specific password duration at a group level different from the default.
Here is a breakdown of how the password expiration is handled by Maximo:
Each group has a password expiration value.
If a user belongs to more than one group, the longest expiration period is the one inherited.
For example, if a user belongs to one group that has a setting of 90 days and another that has a value of 30 days, the user inherits a 90 day expiration setting.
In the case of a user belonging to any groups not containing a password expiration, the user's password will never expire.
You would need to use the Override Password Duration option to set an expiration value for each group the user belongs to.
Once the password expiration settings are set, the clock starts to count down after the password is changed with the expiration settings in place.
NOTE:
If the user existed before the password expiration is set, the password will not expire because the timer does not start until the next password change after the password expiration has been set.
The remedy is to change the user's password after setting the password expiration.
Removing the user from the group the expiration date is set on and adding them back will also work.

IBM Readme for IBM Maximo Asset Management 7.6.1.3 Fix Pack

  Fix Readme Abstract This fix pack updates IBM® Maximo® Asset Management version 7.6.1, 7.6.1.1, and 7.6.1.2 Content IBM Maximo Asset Manag...