Saturday 18 June 2016

Differentiating ReportedBy and AffectedBy when using Classifications in SR

Question

I change the ReportedBy user in the Service Request but I'm not getting an updated list of classifications based on my new User. I can see the classifications that belonged to the original user. Why?

Cause

I'm creating an SR and I select ReportedBy User1, the list of classifications is populated but once I change that user to User2, the classifications aren't being updated based on the updated ReportedBy user.

Answer

The classification is filtered according to the Customer field. When you
add the User1 as Affected By, User1 is also added into Affected Person
that adds the Customer (customer) on the customer field. The customer field
is linked with Affected By person and not Reported By.
So when you change Reported By to User2, the Affected Person and
Customer fields are not changed. That is why an updated list in classifications is not being
displayed when you change the Reported By.


The customer comes from the Affected By, not the Reported By.

1. Go to SR app.
2. New SR
3. Entered Sinclair in Reported By. Sinclair also appeared in the
Affected By and Gillette appeared in the Customer field
4. Tabbed to the Affected By and replaced Sinclair by Reid. Received a
warning message about changing Customer value. I clicked on Accept My
Value.
5. Reid displayed in the Affected By field, and the Customer was
changed from Gillette to DCH.

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